Friday, 7 March 2014

Your hosting provider does not yet support ASP.NET 4.5…

Oh yes it does, I’ve been using .NET 4.5 for *ages* on Azure. Well, it feels like it anyway, but today I got this error after adding an extra couple of dependencies in from NuGet.

It was a simple fix – the stuff I’ve added (Cross Origin Requests) has updated my project but not set it to .NET 4.5.1 which is necessary for it to work. A quick trip to settings land…

image

And now it’s working again. Phew!

2 comments:

Julio Poveda said...

Thanks, i hope it works for my Lightswitch project

Richard Majece said...

It's my fav thing to do. I like it since my college.And I know all the difficulties of this age cause I read this info. It may be interesting for you, too. Computers are very important now.